Call of Duty: Strike Team App Crashes


Call of Duty: Strike Team is a high-performance game, and is only compatible with iPhone 4S or greater, iPod Touch 5th Generation or greater, or iPad 2 and greater.

Devices must also be running iOS 6.0 or later.

For optimal performance, it is recommended that you reboot your device before playing Call of Duty: Strike Team.

If you are experiencing crashes when launching or playing the game, please fully reboot your device then try again.


Previous MonthNext Month
SunMonTueWedThuFriSat