Device Requirements for Pitfall!


Pitfall! is compatible with iOS and Android. The exact devices are listed below:

iOS
  • iPad (1st generation or newer)
  • iPad Mini
  • iPhone (4 or newer)
  • iPod Touch (4th generation or newer)
  • Requires iOS 4.3 or later
Android
  • Acer Iconia Tab A700
  • Google Nexus 7
  • HTC Desire S
  • HTC One X
  • Motorola RAZR MAXX  XT910
  • Motorola Xoom 10" MZ601
  • Samsung Galaxy (S2, S3, Nexus and Tab 10.1)
  • Samsung Galaxy Note II GT-N7100
  • Samsung Galaxy Note N7000
  • Sony Xperia P  LT22i
  • Xperia 5


Previous MonthNext Month
SunMonTueWedThuFriSat